import re
regex = re.compile(r"^([a-z0-9]{2,}).*(\1)$", flags=re.UNICODE | re.MULTILINE)
test_str = ("123123123123\n"
"daddaddaddad\n"
"sadsadasad\n"
"sadsadsad\n"
"121212121\n"
"sasasasasas\n"
"sdsdsdsds\n"
"dsdsdsdsd\n"
"ffffffff\n"
"blahblah\n"
"ioiooioioioi\n"
"popopopopop\n\n\n"
"Hi I dont think this is a spam.\n"
"II loooovve this. It's awesooooommeee!")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")