import Foundation
let pattern = #"^(0|\+33){1} {0,1}(6|7){1}(( |.){0,1}[0-9]{2}){4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
0682928919
0501468879
0715448664
01656565656656
03 02 021 02
+33682928919
06.82.92.89.19
06 82 92 89 19
+336.82.92.89.19
+33 682928919
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)