using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<!ELEMENT\s+\w+\s+\(\W*(\w+)\W*\)";
string input = @"<!ELEMENT DealNumber (#PCDATA) >
<!ELEMENT DealParties (DealParty+)>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}