#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(.*)\|[\s\t]+([0-9.,]+|)([\s\t]+|)\|(.*)"
Local $sString = "02.05.07| 158.73 |test1" & @CRLF & _
"02.05.07| 63,492.00|test2" & @CRLF & _
" | |Взнос наличными на счет" & @CRLF & _
" | |@@CP 00442 XXXXXXXXXXXXXX" & @CRLF & _
" | |КАРАГАНДИНСКИЙ Ф-Л" & @CRLF & _
" | |счет : 1101-879100-398" & @CRLF & _
" | |СЧЕТ КАССЫ" & @CRLF & _
" | |/KNP/1717311" & @CRLF & _
" | |ПОПОЛ СЧ ДОВ 322 ОТ 22,12,06 Ч/З КО" & @CRLF & _
" | |ЗЫРЯД" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")