import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"(.*)\|[\s\t]+([0-9.,]+|)([\s\t]+|)\|(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
02.05.07| 158.73 |test1
02.05.07| 63,492.00|test2
| |Взнос наличными на счет
| |@@CP 00442 XXXXXXXXXXXXXX
| |КАРАГАНДИНСКИЙ Ф-Л
| |счет : 1101-879100-398
| |СЧЕТ КАССЫ
| |/KNP/1717311
| |ПОПОЛ СЧ ДОВ 322 ОТ 22,12,06 Ч/З КО
| |ЗЫРЯД
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)