package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\s*(.*?)\s*\)`)
var str = `14:34:35 - Name:( NAME ) Level( 97 ) Item( ITEM_NAME ) Code( 50401280 ) Unique Number( 842332 13121779 ) Spec Code( 0 ) New( 1 )`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}