$re = '/\(\s*(.*?)\s*\)/';
$str = '14:34:35 - Name:( NAME ) Level( 97 ) Item( ITEM_NAME ) Code( 50401280 ) Unique Number( 842332 13121779 ) Spec Code( 0 ) New( 1 )';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);