const regex = /(?:\[([^\]]*)\]\s*){3}(?:\[[^\]]*\]\s*)*(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\[([^\\]]*)\\]\\s*){3}(?:\\[[^\\]]*\\]\\s*)*(.*)', 'gm')
const str = `<181>Sep 03 04:54:23 172.168.168.152 [2015-09-03 04:54:23,755] [Log Name] [INFO ] [test.audit1] [AUD5454] [default/test1] logged out.
<182>Sep 01 01:33:45 172.168.168.152 [2015-09-01 01:33:45,851] [Log Name] [Critical ] [test.audit2] [AUD53501] [default/test2] logged in.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}