import re
regex = re.compile(r"(?:\[([^\]]*)\]\s*){3}(?:\[[^\]]*\]\s*)*(.*)", flags=re.MULTILINE)
test_str = ("<181>Sep 03 04:54:23 172.168.168.152 [2015-09-03 04:54:23,755] [Log Name] [INFO ] [test.audit1] [AUD5454] [default/test1] logged out.\n\n"
"<182>Sep 01 01:33:45 172.168.168.152 [2015-09-01 01:33:45,851] [Log Name] [Critical ] [test.audit2] [AUD53501] [default/test2] logged in.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")