package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:00|\+)58|0)(?:2(?:12|4[0-9]|5[1-9]|6[0-9]|7[0-8]|8[1-35-8]|9[1-5]|3[45789]))\d{7}$`)
var str = `02121234567
+582121234567
2121234567
(212)123.41.25
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}