re = /^(?:(?:00|\+)58|0)(?:2(?:12|4[0-9]|5[1-9]|6[0-9]|7[0-8]|8[1-35-8]|9[1-5]|3[45789]))\d{7}$/m
str = '02121234567
+582121234567
2121234567
(212)123.41.25
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end