import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?xi)^(\n"
+ "(AT)?U[0-9]{8} | # Austria\n"
+ "(BE)?0[0-9]{9} | # Belgium\n"
+ "(BG)?[0-9]{9,10} | # Bulgaria\n"
+ "(HR)?[0-9]{11} | # Croatia\n"
+ "(CY)?[0-9]{8}L | # Cyprus\n"
+ "(CZ)?[0-9]{8,10} | # Czech Republic\n"
+ "(DE)?[0-9]{9} | # Germany\n"
+ "(DK)?[0-9]{8} | # Denmark\n"
+ "(EE)?[0-9]{9} | # Estonia\n"
+ "(EL|GR)?[0-9]{9} | # Greece\n"
+ "ES[A-Z][0-9]{7}(?:[0-9]|[A-Z]) | # Spain\n"
+ "(FI)?[0-9]{8} | # Finland\n"
+ "(FR)?[0-9A-Z]{2}[0-9]{9} | # France\n"
+ "(GB)?([0-9]{9}([0-9]{3})?|[A-Z]{2}[0-9]{3}) | # United Kingdom\n"
+ "(HU)?[0-9]{8} | # Hungary\n"
+ "(IE)?[0-9]S[0-9]{5}L | # Ireland\n"
+ "(IT)?[0-9]{11} | # Italy\n"
+ "(LT)?([0-9]{9}|[0-9]{12}) | # Lithuania\n"
+ "(LU)?[0-9]{8} | # Luxembourg\n"
+ "(LV)?[0-9]{11} | # Latvia\n"
+ "(MT)?[0-9]{8} | # Malta\n"
+ "(NL)?[0-9]{9}B[0-9]{2} | # Netherlands\n"
+ "(PL)?[0-9]{10} | # Poland\n"
+ "(PT)?[0-9]{9} | # Portugal\n"
+ "(RO)?[0-9]{2,10} | # Romania\n"
+ "(SE)?[0-9]{12} | # Sweden\n"
+ "(SI)?[0-9]{8} | # Slovenia\n"
+ "(SK)?[0-9]{10} # Slovakia\n"
+ ")$";
final String string = "ATU99999999\n"
+ "BE0999999999\n"
+ "BG999999999\n"
+ "HR12345678901\n"
+ "CY99999999L\n"
+ "CZ12345678\n"
+ "DK99999999\n"
+ "EE123456789\n"
+ "FI99999999\n"
+ "FRXX999999999\n"
+ "DE999999999\n"
+ "EL123456789\n"
+ "HU12345678\n"
+ "IE1S23456L\n"
+ "IE1234567T\n"
+ "IE1234567TW\n"
+ "IE1234567FA\n"
+ "ESA12345678\n"
+ "ESZ1234567E";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}