import re
regex = re.compile((r"(?xi)^(\n"
r"(AT)?U[0-9]{8} | # Austria\n"
r"(BE)?0[0-9]{9} | # Belgium\n"
r"(BG)?[0-9]{9,10} | # Bulgaria\n"
r"(HR)?[0-9]{11} | # Croatia\n"
r"(CY)?[0-9]{8}L | # Cyprus\n"
r"(CZ)?[0-9]{8,10} | # Czech Republic\n"
r"(DE)?[0-9]{9} | # Germany\n"
r"(DK)?[0-9]{8} | # Denmark\n"
r"(EE)?[0-9]{9} | # Estonia\n"
r"(EL|GR)?[0-9]{9} | # Greece\n"
r"ES[A-Z][0-9]{7}(?:[0-9]|[A-Z]) | # Spain\n"
r"(FI)?[0-9]{8} | # Finland\n"
r"(FR)?[0-9A-Z]{2}[0-9]{9} | # France\n"
r"(GB)?([0-9]{9}([0-9]{3})?|[A-Z]{2}[0-9]{3}) | # United Kingdom\n"
r"(HU)?[0-9]{8} | # Hungary\n"
r"(IE)?[0-9]S[0-9]{5}L | # Ireland\n"
r"(IT)?[0-9]{11} | # Italy\n"
r"(LT)?([0-9]{9}|[0-9]{12}) | # Lithuania\n"
r"(LU)?[0-9]{8} | # Luxembourg\n"
r"(LV)?[0-9]{11} | # Latvia\n"
r"(MT)?[0-9]{8} | # Malta\n"
r"(NL)?[0-9]{9}B[0-9]{2} | # Netherlands\n"
r"(PL)?[0-9]{10} | # Poland\n"
r"(PT)?[0-9]{9} | # Portugal\n"
r"(RO)?[0-9]{2,10} | # Romania\n"
r"(SE)?[0-9]{12} | # Sweden\n"
r"(SI)?[0-9]{8} | # Slovenia\n"
r"(SK)?[0-9]{10} # Slovakia\n"
r")$"), flags=re.MULTILINE)
test_str = ("ATU99999999\n"
"BE0999999999\n"
"BG999999999\n"
"HR12345678901\n"
"CY99999999L\n"
"CZ12345678\n"
"DK99999999\n"
"EE123456789\n"
"FI99999999\n"
"FRXX999999999\n"
"DE999999999\n"
"EL123456789\n"
"HU12345678\n"
"IE1S23456L\n"
"IE1234567T\n"
"IE1234567TW\n"
"IE1234567FA\n"
"ESA12345678\n"
"ESZ1234567E")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")