$re = '/hello!/';
$str = 'hello
hello!
hello!!
hello-!
hello w34~342`!!
hello! w34~342`!!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);