re = /hello!/
str = 'hello
hello!
hello!!
hello-!
hello w34~342`!!
hello! w34~342`!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end