import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\{word1\\/)([\\w-]+)\\/(\\w+)";
final String string = "{word1/G_KP8zXsDp8/word2}\n"
+ "{word1/GKP8zXsDp8/word2}\n"
+ "{word1/G-KP8zXsDp8/word2}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}