$re = '/({word1\/)([\w-]+)\/(\w+)/';
$str = '{word1/G_KP8zXsDp8/word2}
{word1/GKP8zXsDp8/word2}
{word1/G-KP8zXsDp8/word2}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);