use strict;
my $str = '2014-10-29T19:20:36+00:00 DEBUG (7): ERP_SERVICE_CALL:POST:RESPONSE: "{/"status/":/"success/",/"code/":400,/"data/":{/"batch_id/":/"M-1331/",/"order_total/":4,/"success_total/":0,/"orders/":[{/"order_id/":/"1272749/",/"status/":/"error/",/"message/":/"order_id: 1272749 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051},{/"order_id/":/"1272750/",/"status/":/"error/",/"message/":/"order_id: 1272750 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051},{/"order_id/":/"1272751/",/"status/":/"error/",/"message/":/"order_id: 1272751 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051},{/"order_id/":/"1272752/",/"status/":/"error/",/"message/":/"order_id: 1272752 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051}]}}"';
my $regex = qr/batch_id\/\":\/\"(?<batch_id>[^\/]+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}