re = /batch_id\/\":\/\"(?<batch_id>[^\/]+)/
str = '2014-10-29T19:20:36+00:00 DEBUG (7): ERP_SERVICE_CALL:POST:RESPONSE: "{/"status/":/"success/",/"code/":400,/"data/":{/"batch_id/":/"M-1331/",/"order_total/":4,/"success_total/":0,/"orders/":[{/"order_id/":/"1272749/",/"status/":/"error/",/"message/":/"order_id: 1272749 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051},{/"order_id/":/"1272750/",/"status/":/"error/",/"message/":/"order_id: 1272750 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051},{/"order_id/":/"1272751/",/"status/":/"error/",/"message/":/"order_id: 1272751 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051},{/"order_id/":/"1272752/",/"status/":/"error/",/"message/":/"order_id: 1272752 //nCode: INVALID_KEY_OR_REF//nDetails: Invalid item reference key. Item value provided: ASB-000219 //nforEach(EC_Libs-4.0.6.js:70),forEach(EC_Libs-4.0.6.js:70),restletwrapper(null$lib:4) //n[no stack trace]/",/"customer_internal_id/":/"16873/",/"customer_id/":1301051}]}}"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end