using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\-a-z]+$";
string input = @"pink-floyd
INVALID
tiësto-NOPE
deadmaus
deadbeef
0xDEADBEEF
none-of-these-&&&
or-these-???
just-lowercase-and-";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}