using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=[0-9,]+$)((?<=,|^)[0-9]{1,2})(?=,|$)";
string input = @"31,5,46,7,86";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}