#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^(.\()(?=(.*)$)|\G.\("
Local $sString = "a(b(c(d(e(f("
Local $sSubst = "\1\2)?+"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)