using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.\()(?=(.*)$)|\G.\(";
string substitution = @"\1\2)?+";
string input = @"a(b(c(d(e(f(";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}