package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]+([_.-][a-z0-9]+)*@[a-z0-9]+([_.-]Â[a-z0-9]+)*\.(com|ca|net|org|fr|us|qc.ca|gouv.qc.ca)$`)
var str = `foo@hotmail.com
foo.bar@gg.com
ojoihoih`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}