$re = '/^[a-z0-9]+([_.-][a-z0-9]+)*@[a-z0-9]+([_.-]Â[a-z0-9]+)*\.(com|ca|net|org|fr|us|qc.ca|gouv.qc.ca)$/m';
$str = 'foo@hotmail.com
foo.bar@gg.com
ojoihoih';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);