package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<((?:>>|[^>])*)>`)
var str = `<test>>more> or even more>
And <here> it matches.
And <also>>here> is a match
Im <guessing this is>> correct.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}