// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<((?:>>|[^>])*)>").unwrap();
let string = "<test>>more> or even more>
And <here> it matches.
And <also>>here> is a match
Im <guessing this is>> correct.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}