package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S+)\.\.\.$`)
var str = `Do not match this. This sentence ends in the last word...
Do not match this. This sentence ends in the last word.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}