$re = '/(\S+)\.\.\.$/m';
$str = 'Do not match this. This sentence ends in the last word...
Do not match this. This sentence ends in the last word.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);