#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z0-9]{1,3}(?:,[ ]?[A-Z0-9]{1,3})*(?:,[ ]?)?$"
Local $sString = "Valid input could be: 'B' 'BR' 'BRU' 'BRU,' 'BRU, ' 'BRU, A' 'BRU, ALC' 'BRU, ALC,B' and so on." & @CRLF & _
"" & @CRLF & _
"Invalid input would be 'BRUU' or 'BRU ALC'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"BR" & @CRLF & _
"BRU" & @CRLF & _
"BRU," & @CRLF & _
"BRU, " & @CRLF & _
"BRU, A" & @CRLF & _
"BRU, ALC" & @CRLF & _
"BRU, ALC,B" & @CRLF & _
"BRUU" & @CRLF & _
"BRU ALC" & @CRLF & _
"B," & @CRLF & _
"BR," & @CRLF & _
"B, " & @CRLF & _
"BR,"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")