$re = '/^[A-Z0-9]{1,3}(?:,[ ]?[A-Z0-9]{1,3})*(?:,[ ]?)?$/m';
$str = 'Valid input could be: \'B\' \'BR\' \'BRU\' \'BRU,\' \'BRU, \' \'BRU, A\' \'BRU, ALC\' \'BRU, ALC,B\' and so on.
Invalid input would be \'BRUU\' or \'BRU ALC\'
BR
BRU
BRU,
BRU,
BRU, A
BRU, ALC
BRU, ALC,B
BRUU
BRU ALC
B,
BR,
B,
BR,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);