import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?.*?\\.ru.*?worm";
final String string = "http://www.malwarecheap.ru/files/worm.exe\n"
+ "https://tarnacop.ro/dl/worm\n"
+ "ftp://pwned.ru/exploits/worm.zip";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}