re = /https?.*?\.ru.*?worm/m
str = 'http://www.malwarecheap.ru/files/worm.exe
https://tarnacop.ro/dl/worm
ftp://pwned.ru/exploits/worm.zip'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end