using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",.*?,.*?'(.*?)'";
string input = @"$phpcsFile->addError($error, 0, 'FoundWithSymbols', $data);";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}