// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a.*\shref=[\"\'](?:(?:\w+)://)*((?:[\w-]+\.)+(?:[\w-]+))(?::\d+)?(?:/|$)?(?:[^\s]+)?[\"\'].*>"#).unwrap();
let string = "<a href=\"http://www.pochta.ru\">Почта</a>
<a href=\"http://top100.rambler.ru/top100/All/rate21.0.shtml.ru\"><img src=\"http://pics.rbc.ru/img/ver99/counter_rambler.gif\" alt=\"Rambler's Top100 Service\" width=88 height=31 border=0></a>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}