using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"1[\\:/]72";
string input = @"test string 1/72
test string 1\72
test string 1:72";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}