package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:0?\d|1[0-2]|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)[ \/-](?:0?\d|1\d|2\d|3[0-1])[ \/-]\d{4}`)
var str = `1/1/1987 09-21-2018 mar 8 1969 7 17 1975
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}