use strict;
my $str = '1/1/1987 09-21-2018 mar 8 1969 7 17 1975
';
my $regex = qr/(?:0?\d|1[0-2]|jan|feb|mar|apr|may|jun|jul|aug|sep|oct|nov|dec)[ \/-](?:0?\d|1\d|2\d|3[0-1])[ \/-]\d{4}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}