re = /(([1-9]{0,1}[0-9]{0,2}|2[0-4][0-9]|25[0-5])\.){3}([1-9]{0,1}[0-9]{0,2}|2[0-4][0-9]|25[0-5])\/([1-2][0-9]|3[0-1])/
str = '192.168.10.0/24'
# Print the match result
str.match(re) do |match|
puts match.to_s
end