package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`foo\d*bar`)
var str = `foo1bar # Match
foo234bar # Match
foobar # Not a Match`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}