$re = '/foo\d*bar/';
$str = 'foo1bar # Match
foo234bar # Match
foobar # Not a Match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);