package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)@var\s*([^\s]+)`)
var str = `/** * Identity * * @var integer */`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}