$re = '/@var\s*([^\s]+)/i';
$str = '/** * Identity * * @var integer */';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);