$re = '/(?!.*\/{2})(?!.*\.{3})^[A-Za-z\/\.]*$/';
$str = 'aaa/asdasda/adada/../.././';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);