package main
import (
    "regexp"
    "fmt"
)
func main() {
    var re = regexp.MustCompile(`[A-Z0-9]+`)
    var str = `First \"string\" 1is "Hello \"WOrld\"!" `
    
    for i, match := range re.FindAllString(str, -1) {
        fmt.Println(match, "found at index", i)
    }
}