#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ",(?=(?:[^"]*"[^"]*")*[^"]*$)"
Local $sString = "fontSize=16.0, fontFamily=sans, align=0, color=FF0000, text="foo, bar""
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)