re = /,(?=(?:[^"]*"[^"]*")*[^"]*$)/
str = 'fontSize=16.0, fontFamily=sans, align=0, color=FF0000, text="foo, bar"'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result