package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w\s*){7,}\w$`)
var str = `Abcd1234
Abcd 1234
Abcd1234
Abcd1234 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}