using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^|]+(?=(?:\|[^|]+\|?){4}$)";
string input = @"78|Indonesia|Pamela|Reid|preid25@gravatar.com|147.3.67.193";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}