const regex = new RegExp('[^|]+(?=(?:\\|[^|]+\\|?){4}$)', 'g')
const str = `78|Indonesia|Pamela|Reid|preid25@gravatar.com|147.3.67.193`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}